Updating Blizzard Launcher stuck

Technical Support
Hello , as the title says it , my updating launcher gets stuck at around 70%. I have tried anything from the other posts - deleted the Battlenet folder , the Updates, the Cache , everything ! The only thing that did was switch from the Launcher getting stuck to the Agent getting stuck . I also followed the internet options thingy in internet explorer . Nothing. Can some one help ?

Please could you delete the following folders and see if the issue is fixed?

C:\ProgramData\Blizzard Entertainment\Battle.net\Cache

There's a guide on doing this here: https://eu.battle.net/support/en/article/deleting-the-battlenet-tools-folder-windows
Hello there, thank you for the reply . I've done this again and same result -now the Blizzard Update Agent is stuck :|
Hello! Same problem here too. When i want to play with Diablo, or WoW, this happening all the time. Blizzard Launcher stuck at 70%. I've done this too. 2-3-4 computer restart sometimes solve the problem
This happend to me on my laptop and also to a friends laptop although seems to work on PC fine, my husband uninstalled wow from the said laptop, defragged then reinstalled, it then worked for a couple of days and then broke again, very frustrating, would have thought that seeing this isnt a one off it must be a technical and hopefully Blizz will send out a repair or permanent solution?
Alternatively you can by pass the launcher and load direct from the file but this only works until a patch is released.
While this can sometimes be caused by Agent problems, it is usually an issue with security software or Windows. Make sure you always run the Launcher as Admin (either by right-clicking or setting in Properties). It also helps to set anti-virus programs to ignore the World of Warcraft and Battle.net folders.
it isnt working for me =(
And i have the problem over a week now :/

Hoping to see more suggestions

if the Launcher is stuck, then usually something is interfering with the Update Agent, as Doomsinger says.

Can you let us know which anti virus program(s) you're using?
Hello Lurdlespor!

I don't use any anti virus program. i tried everything, but didn't working any. 2-3 hour and it's working. But it's so annoying, and the players 5-6% have this problem.
Having the same problem
Same problem here.

If you're eager to play anyways you can start wow.exe and still play the game!
Yes, but i want to patch my sc II too. And same problem
Hi there,

Can you please try the following steps? There's quite a few but since this issue can be caused due to a few different reasons, we need to make sure we go through everything.

1). It's mentioned above, but we really do need to make sure that you remove the Battle.net Tools folder. This should force the update agent to well, update, and the new version should hopefully work when updating:

2). Make sure you delete the Updates folder in your game directory, this should just be in the base directory of whichever game you're trying to patch.

3). Check your Internet Explorer settings. The Launcher uses Internet Explorer no matter which browser you have set as your default. Go into Internet Explorer > Tools > Internet Options> Connections> LAN settings and make sure that you de-select Automatically Detect settings.

And make sure that you haveUse Automatic configuration Script and Use a Proxy server not checked.

4). Remove any .mfil, .tfil and .pfil files from the game directory, then launch it again. This will force a repair of the client, and ensure there isn't an issue with the client itself.

5). In case the issue is related to another program interfering, try running the game when Windows is in a Selective Startup mode. Just to ensure nothing else non essential is running:

6). Make sure that Secondary Logon service is enabled:

Let us know if you still experience issues with checking for updates after this.

After i tried the first method the launcher is now stuck in a differend place and can't update.
It is currently saying "Updating Blizzard Update Agent...". It's now stuck at 40%.

Tried method 5 aswell, didn't work.
same problem
Same stuck on the "updating blizzard update agent" at about 30-40%, after trying all these things.
Was working yesterday but was stuck on updating for a week or so before that.
So now its not working again...

I cant even launch the game using the wow.exe file
It's still the same after trying those steps out.
It worked perfectly fine last night but when I got back from work my sc2 didn't work at all and wow toke long time to open.
Now my wow has same issue as my SC2, tried to reinstall sc2 and can't even get it started when the launcher starts updating something.
same here. cant log in anymoar.
Had this issue this morning, no firewall, .mfil, .tfil and .pfil files all deleted, and run as admin did not work,

I went to https://eu.battle.net/support/en/article/deleting-the-battlenet-tools-folder-windows?utm_source=internal-support_forums&utm_medium=posting&utm_campaign=BlizzardCSEU&utm_content=070413

And did these steps (i had no agent exe so went straight onto 2+)

After I had deleted the Battlenet folder it updated successfuly.

Hope it works for all you guys!
Hey guys, had this problem on my bros laptop recently and I think I found a solutions:

Before trying anything else, try using "(C:) > Program files (possibly (x86) ) > World of Warcraft > Wow.exe"

Open Internet Explorer > Tools > Internet Options > Connections > LAN Settings > Uncheck the "Automatically detect settings" and "Use a proxy server for your LAN..>" boxes.

If you have Mozilla Firefox installed, follow these steps:
Open Mozilla firefox > Options > Go to the "Advanced" tab > Find the "Connections" section and open "Settings" > Make sure the "No proxy" bullet point is selected.

For these steps, make sure "Show hidden files and folders" in selected in you Control Panel > Appearance and Personalization > Folder Options > Show hidden files and folders. Then go to (C:) > Program Data > then delete the "Battle.net" and "Blizzard Entertainment" folders.

That's all I've got for now, If I think of anything else I'll let you guys know.

Join the Conversation

Return to Forum