Blizzard updater stuck at 70%, can't update to patch.

Technical Support
Hey, I've been trying to log onto WoW for a couple of hours, but my launcher just constatntly gets stuck at 70%. I've gone through all of the options that I've found in other threads, but nothing has worked. I have found that I can bypass the launcher and get straight into WoW and log on, but it tells me " Patch Required. Press the restart button below to exit World of Warcraft and download the patch." upon clicking "Restart" however, the game tells me "Failed to apply patch. Please try again later. IF this problem persists you may need to reinstall or contact technical support."

I've done everything mentioned short of reinstalling, and seems as my download rate is barely 200kb/s I just thought I should try and see if there's anything new I can try. I'm running windows 8 and Mcafee antivirus and yes I've tried everything with my antivirus turned off.
same problam for the 2 day now and yesterday what i used to fix it aint working anymore so bliz wtf come on
I had a problem for a few days where the launcher would take about 30 munutes to load, so to bypass it I just launched WoW from the folder location. I can't do that today because of a patch that I need to download from the launcher which doesn't load.
Can you please delete this folder and try again? :-

Can you please delete this folder and try again? :-


No joy... atleast not for me
Still nothing, never had this problem before.
Had same problem, a friend of mine sent me the specific patch file; download and put it in %wowfolder%/Updates!QQkThC5A!ZyC1eUB836rM8M1A0HGzjSa_docr4wZ8mIbvuPS2bFc
I don't have an update folder in my WoW folder.
I just linked this in another post.
Try some of the stuff there.This error doesn't have a straight forward answer.Different things work for different people,so who knows.
Checked that thread out this morning, tried everything yet it yielded no results.

Can you please try removing the Updates folder found in your World of Warcraft directory, then launch the game again?

If that doesn't work, also in the World of Warcraft folder, can you remove the wow.mfil file, then run the game again?

Please let us know what happens.
I had this problem for 4 days with the updater and tried everything mentioned here and on other threads.
I eventually got round it by uninstalling my Mcafee Anti-virus, rebooting and then the launcher worked and downloaded the required patch.
Even though Mcafee was turned off, even after a selective startup, it was still finding a way to work in the background and block the launcher update so uninstalling it was the only option left to me (which worked).

This may not work for you Clarence but if all else fails then it may be worth a try :)

Join the Conversation

Return to Forum