Armored Bloodwing - Redemption Problem

Customer Support
Hi there.

I've just purchased the Armored Bloodwing (Exciting!) However, when I went to redeem it, it said that my WoW license could not redeem it. However, I think this was because my game time was due to run out today, i've since renewed it. However, it won't let me redeem the code - apparently too many attempts have been made.

I'm pretty keen to redeem this. Can something be done?

Thanks.
Did you buy it on the EU or US site? (basically did you pay it in dollars?)
It was through the EU Blizzard Store. Paid in GBP.
What message are you getting exactly? Could be it's not processed yet (I can't even access the EU store at the moment) since likely lots of people went and bought it at the same time.
"Too many attempts. Try again later."

I've researched and GMs were able to help, so i've made a ticket also. I'm just curious what the expected wait time is to try again later. I've bought countless things from the Blizzard Store so never really came across this problem.
In computer terms try again later means 'later', not a fixed time I'm afraid ;) Honestly I'd wait for the time being. Every time there's a new store mount/pet the whole thing wobbles a bit. Is it just saying 'Too many attempts' or also adding a "503" code next to the error somewhere?
Ah - a little update, it's finally worked and i've got it now, although thank you for your assistance. :)
Due to the popularity of the mount, there is currently a processing queue which is why it was delayed.

Glad to see you got it now though. :)
I also believe i'm having the same problem :<
I redeemed my mount like 999 times i mean i tryed i guess still not getting it!?

Join the Conversation

Return to Forum