libcef.dll missing

Technical Support
Got an error saying "libcef.dll is missing, you might have to reinstall the program" from WoW browser or something. Didn't notice it was a WoW error untill I got it on a different pc too. It didn't look like it did anything, though; my character logged in fine. Except that my open ticket 'form' is like it used to be: a black box instead of the new online support browser forms.

Only got it today after that small patch was downloaded on two different pcs. One of them doesn't even have any addons installed.

edit (got it again):
WowBrowserProxy.exe - System error
The program could not be started since libcef.dll is missing on your computer. You might be able to solve this issue by reinstalling the program.
I got the same thing :/ Dunno wth is happening. Imma make another thread concering this issue.
same thing oO
Same thing has happened to me, I kept logging on and being kicked off within seconds, so I deleted WoW completely, reinstalled and got an error message saying Libcef.dll is missing, please reinstall, or something like that. Whats going on???
Hi there,

This file is related to the Chromium browser we're using for the in-game knowledge database.

If this file is missing, try running the Repair found on the Launcher under the Help menu.

If that doesn't help, try removing the Utils folder found in your World of Warcraft directory, as that's where this should be. Running the Launcher again (and maybe using the Repair Tool) should force this to be completely redownloaded, which should fix the issue.
Lurdlespor (great name by the way),

I award you 10/10 for service my good man, I deleted the Utils folder as mentioned and it worked first time.

Lurdlespor (your name really sounds like a baby murloc, thats how I visualise you haha) thank you for the prompt advice, I've just run the repair tool from the help menu in launcher and it hasn't fixed it. Going to try the other now :)
Thanks Lurdlespor! I got the same error last night on my new PC, deleted the utils folder just now and problem fixed. You're a gem.
Haha, glad to hear it worked :)

But yeah, I'm more a washing machine than a baby murloc.
Thanks mate!!!!!
it worked not for me :( the game shuts down after few seconds of gaming ;_;
Lamea are you getting the same message? Or is the game just closing down with no error?
I got the same error message today, after being away from the game for over half a year.

I used the Repair Tool first, which didn't help.
Then I removed the Utils folder and started the Launcher and used the Repair Tool again and then an error occurred while it was repairing.
I had to restart the Launcher and it took a while until I could click Play.
When I logged on my character, I didn't get any error messages, even though the Utils folder is missing :S
I got same error after returning after a years break..
Have tried use repair tool, then removed Utils and then repaired again.

It removed my error messages but wow closes after a few seconds now.
Thanks for the help, Lurdlespor! I did the repair and it didn't work until I removed the 'Untils Folder' two out of two ain't bad hehe XD

Great name, btw - love it!
thank you very much for this fix. I was in the same position as others, recived 7 days free game time, so decided to come back and got this issue.

The initial repair did nothing, but deleting the folder and then running the repair fixed it.
A me da questo errore da due giorni!
Inoltre ho fatto quanto riportato in discussione ma mi da un errore critico e mi fa uscire dal gioco.
Nive, these forums are English only, if you want to post in Italian there's also an Italian section.
Having this issue atm after coming back to the game after half a year. Game usually crashes after a few seconds-minutes, i just get the classic "is not responding" message from windows. Tried reinstalling the game completely, tried repair, tried deleting the utility folder and still no luck. Any advice?

Edit: It doesnt crash unless i for example change settings or go in combat, but if i do (and i need to, cant change settings since they reset as wow crashes) im sure to freeze within a few seconds.

Join the Conversation

Return to Forum