Free character migration issue (25.09)

Technical Support

I am trying to transfer some characters from Silvermoon to Kilrogg since it is currently free for Alliance chars, but when i try to access the FCM page from my Account page it just says:

An error has occurred.
Back to Account Management

Does anyone else have this issue? Thank you!
Same issue here, probably due to the service being overloaded. 1300+ que on draenor atm :<
Hmm reset day EU and not working. Perhaps they hope people will use paid one again.

Yeah I feel your Draenor queue pain
Managed to transfer yesterday, i used Internet explorer and it didnt say Error anymore. I tested again with chrome at the same time and chrome still said error. So if you get the "Error" thing when entering the FCM page just switch to internet explorer and it should work!
^ Nice try internet explorer nice try, still not using you, you piece of s***. Tried but still didn't work.
IE is actually a very good browser nowadays (no, I don't use it, but still). The issue is that FCM is not open at the moment.

PS pls don't necro.

Join the Conversation

Return to Forum