Launcher stuck at non-critical updates & 13.9GB DL'd

Technical Support
1 2 3 6 Next
Hi everyone,
I did a WoW install from scratch with WoW-4.0.0-WOW-enGB-Installer.exe today. All went well until I had downloaded 13.9GB, according to the connection info window. Then the launcher started to apply non-critical updates, but it was still doing this 2 hours later. So I rebooted, but the problem persists.

The symptoms:
-The Launcher states it is at v4.0.3.13329.
-It is stuck at "Applying non-critical updates. This will take some time."
-It isn't really updating files. I checked with the Process Monitor from Microsofts Sysinternals suite. Launcher.exe constantly reads various files, for example \Data\enGB\speech-enGB.MPQ, \Data\art.MPQ or Data\world.MPQ. It does ReadFile operations -successfully - with very high frequency, sometimes 50 times in a row, each taking only a split second. It NEVER writes anything though.
-Launcher.exe sits at 100% CPU (of one core)
-There is no network activity, just some uploading if I enable P2P

The resulting problem:
I can't really play. I know that it should say 2x GB downloaded in the connection info, but the Launcher will never continue downloading. When I do go ingame, I constantly get the loading bars that show the client streaming data when I'm in zones with Catacylsm-related content. There is definiatly data missing.

OS: Windows 7 64-bit. Non of the files are write-locked. UAC is disabled anyway. I tried to run the Launcher as admin. I already ran the repair tool, it stated that WoW was repaired successfully, but nothing happend otherwise.
Account is already upgraded to Cataclysm.

12:00:55.9928 Launcher version
12:00:56.9653 Starting PatchOnDemand system...
12:00:56.9653 Retrieving torrent information from the server.
12:01:00.6477 Play-on-demand initial values:
12:01:00.6477 7307788288/7307788288
12:01:00.6477 0/0
12:01:00.6477 7653031936/7653031936
12:01:16.6750 Time-out while loading patch notes from ''

It looks the same every time it is started. I can see the patch notes in the Launcher even though it says something about a timeout.
Hi, I read on the old forums once that when it was doing the 'non-critical updates', its sorting out game files on the hard drive for easier access times.
I'm not 100% sure about that, well I reinstalled wow too from 3.x.x, and had the same message for over an hour.

Edit: Btw it does complete what its doing, I just left my computer alone in that time.
After my last post, I restarted the launcher. Since then (6 hours) it sat at "Applying non-critical updates", at 100% CPU, transferred nothing and had no disk writes, HDD is idle.
I don't think this will resolve itself.
/EDIT: I started the game, but it is still streaming lots of data on-demand. The download is definitely not finished, but it won't continue.
Hmm yeah, seems more complicated than I thought it would be.

Edit: Actually have you tried restarting your computer?
I did it earlier
04/12/2010 12:03Posted by Malstrond
So I rebooted, but the problem persists.

but will try again and report back in 30min or so.
Yep, I meant like after the 6 hours of it Applying non-critical updates , probably got stuck or something along the way.
When the launcher states Applying non-critical updates feel free to just click the play button and head online, you shouldn't notice any problems whatsoever. My guess it is a glitch in the downloading system.
Rebooted, let it sit for a while, problem is still there.

@Illya: Yes I know that there is a problem where the launcher will always say Applying non-critical updates even if everything is complete for some people.

My issue is different. I have NOT downloaded all data. Connection info window says "Completed: 13.9 of 13.9 GB", I know from friends that it should be more.

I get loading bars in the character selection when selecting a character and when I go ingame, I often see the "loading circle" thingie that appears when the client streams on-demand data, and I can see the low-res textures being replaced with the high-res ones. Using a traffic monitor I can see that the client it is downloading lots of stuff at 1-2mbit/s when going into new zones, which causes horrible latency.
But the launcher will not acknowledge that the game is not complete because it's stuck. That is my problem.
Can you try running the repair tool? This might force the launcher to realise there is still data to be downloaded.
I ran the repair tool, but the Launcher is still stuck.

I also tried deleting the WTF and Cache folders, when I do this, it still says "Applying non-critical updates", but the green progress bar is now empty instead of full. When I restore the WTF folder from backup, it's full again, but it always says "Applying non-critical updates" without any HDD activity.

However, I noticed something I didn't before.
The ...\Temp folder contains wow- and wow-
Is this correct?
The other folders are labled enGB, for example it's ...\Data\enGB and ...\Cache\WDB\enGB\.
This is fine, the tools updates are usually enUS.
There seem to be other people with this issue in the US, i.e.

I know that the Launcher writes stuff to ...\Data\Cache\ when it's applying non-critical updates. As far as I know this is also where the streaming content goes.

So I deleted this folder and let it be recreated. I also downloaded the build 13329 EU wow.tfil/mfil files from and compared them with my files. Same checksum, so this doesn't seem to be the problem.

The folder was recreated, but that didn't fix the issue.

Other things I did:
-Safe mode with networking -> No fix.
-Copying the client to my laptop. Launcher starts up, calibrates, and is instantly stuck at the exact same point, not doing anything.

My (un)educated guess is that the following:
-Even after you're at 13329, you don't have all the data, it is downloaded through the "streaming" system, not through the "wow-xxxxx-xxxxx-Win-final.MPQ" files, be it ingame or by the Launcher.
-The last patch introduced the issue that the Launcher never finishes migrating files to \Data\Cache (i.e. converting the sound files), which is the "applying non-critical updates" phase (The \Data\Cache foldaer stops at 6.16GB for me).
-The first time this phase is triggered is when all data from the "wow-xxxxx-xxxxx-Win-final.MPQ" files is downloaded. It will never finished, so you can't get the streaming non-patch data.
--> This issue can manifest ONLY for people that started an install from scratch AFTER the patch that introduced the launcher bug, which is why it isn't being noticed that much.

After all is said and done, the Launcher is still stuck and I still get lots of "Important game data is being downloaded" ingame (--> horrible ping), which means that I still can't download the data I need without being ingame. I can't really play that way.

I will install the game from scratch, but the German (deDE) client, on a different PC, to avoid all similarites and let it download through the night.
I'll report back tomorrow.
So, any luck? I got this problem after installing from the internet client too...
Repair tool and starting stuff with admin rights didn't work.
<br/>Starting from wow.exe works and it doesn't download stuff.
Oh, and I have an SSD!
Give this a try,
I believe the applying non-critical updates means game is building cache of files in your Data\Cache folder. My guess is it is some kind of unpacking of less important files (sounds) which were packed in order to let you download game faster.

If you clear the Data\Cache folder, Launcher should build it again from scratch. Perhaps your cache is bugged, which makes your launcher stuck in infinite loop. Also make sure launcher will have the rights to write to cache folder, once you clear it (run it as admin if you didn't install the game into public folder).
Im having the same issue, stuck on applying non-critical patch
this is from my log

13:08:32.4012 Launcher version
13:08:32.8898 Starting PatchOnDemand system...
13:08:32.8898 Retrieving torrent information from the server.
13:08:35.1534 Play-on-demand initial values:
13:08:35.1534 7307788288/7307788288
13:08:35.1534 0/0
13:08:35.1534 7653031936/7653031936
13:08:51.1690 Time-out while loading patch notes from '

Is this normal? any suggestions or help regarding this issue?
05/12/2010 10:32Posted by Vitorazor
So, any luck? I got this problem after installing from the internet client too...

No, redownladed it from scratch during last night, the problem persists.
I'm currently playing while streaming data, but it sucks. Travelling everywhere and getting all the new flight paths wasn't fun.

05/12/2010 13:03Posted by Isma
If you clear the Data\Cache folder

I already rebuilt the \Data\Cache folder, gets stuck at the 6.16GB just as before.
[quote="9991710012"]I know that the Launcher writes stuff to ...\Data\Cache\ when it's applying non-critical updates. [...] So I deleted this folder and let it be recreated.[/quote]

[quote="9991914968"]Give this a try,[/quote]
Fixing the file permissions (step 3 in that post) doesn't apply because I have UAC disabled anyway and my user, system and admin all have R/W access, I even set it to "Everyone", step 1 (hardware failrue) doesn't apply because the problem appears on two PCs, both installing from scratch; step 2 is rebuilding the \Data\Cache folder which I mentioned above.

/EDIT: Hm, can't seem to get the quotes to work.
Same problem here, Win7 64 bit and the whole game was freshly installed after the new patch came out...
Same issue here.

downloader, uploader, launcher and wow.exe all have admin rights, have run repair tool twice, rebooted twice, still sitting at 13.9gb and applying non critical updates. Been doing that approx 16 hours total now.

Originally it halted on 8.6gb, ran game, quit, and it realised it had more to download and got up to 13.9gb which is where it has been sitting for the past 4 hours, including a repair and reboot in that time.

Windows 7 64bit, installed in the x86 folder as is default. WoW version number showing as v4.0.3.13329.

Fresh install of full wow, bc, WOTL and Cata from digital download.

Hope that info helps a solution be found =)

Join the Conversation

Return to Forum