Mac et API Metal non disponible

Assistance technique
Bonjour à tous,

Dans un premier temps je tiens a remercier ceux qui pendrons le temps de lire mon post et éventuellement de répondre.

Configuration :
- Systeme : El capitan, version : 10.11.6 (15G1421)
- macbook pro retina 15" mi-2014
- i7 2,5 Ghz
- 16 go de ram
- Nvidia Geforce GT 750M 2048Mo

Deuxièmement, pour mon travail je suis OBLIGE de travailler sur mac. Donc voila pour quoi j'ai un mac et que je joue dessus.
Si je commence par dire ça c'est pour éviter les débats du genre " pourquoi tu joue sur mac ect ect".

Sinon concernant mon problème ...
Depuis quelque temps je me suis reconnecté sur wow, et à ma grande surprise en voulant configurer les options graphiques j'ai pu voir que l'API graphique Metal n'est pas disponible pour moi dans le menu déroulant. Il n'y a que OpenGL de sélectionnable.

J'ai fais pas mal de recherche, deja Metal est de base dans El capitan si j'ai bien compris et pour les mac de mini 2012.
J'ai cherche sur ce forum, sur le net, je n'ai trouvé personne avec le même problème.

Pourtant, avant d'avoir ce macbook, j'avais un iMac de fin 2013 ( non retina) et sur celui ci je pouvais choisir l'api Metal.

Dans la mesure ou les performances sont vraiment bien meilleurs avec Metal sous mac, cela me dérange vraiment de ne pas pouvoir l'utilisé.

Donc je viens vers vous pour savoir si vous avez d'éventuel informations ? Peut être un truc système a activer ou configurer ??

Parce que je ne penses pas que ma configuration ne soit pas compatible avec cette API ..... dans la mesure ou il est plus récents que mon iMac, et que mon iMac avait un Nvida aussi, après c'était une GTX 780M, mais bon je penses que les GT en bénéficient elles aussi ! Vu que les intel iris oui !

Voila ... un grand merci a celui qui aurait un solution car la je sais vraiment pas quoi faire :)
Personne n'a deja eu ce genre de problème ? ou connais quelqu'un dans le meme cas que moi :/ ?
Salut, j'ai exactement le même Mac que toi, chez moi je l'ai, à la différence que pour ma part je suis sur macOS 10.12 Sierra, la mise à jour juste après El Capitan, essaye de mettre à jour, je pense que ça te sauvera ;)
Merci de t'as réponse

Ce que je ne comprend pas c'est que j'ai vu pas mal de posts de personnes jouant sous mac avec l'api Metal et ils étaient sous EL capitan !
Perso j'aime pas trop Sierra!
Mais bon pour le coup pas trop le choix je crois bien :/
Bonjour,

même problème que toi, cela faisait 2 mois que j'avais pas lancé WoW et hier, après l'installation d'une GTX 980 TI dans mon MacPro, je test WoW et je remarque que l'API Metal n'est plus disponible, alors qu'elle l'était avec ma GTX 680 en début d'année.
C'est peut-être comme avec Starcraft II, il faut maintenant ( depuis la dernière maj) passer à Sierra pour profiter de WoW avec Metal. Dommage pour ceux qui doivent rester sous EL Captain.
Je suis en train de faire la Maj OSX vers Sierra, on verra bien.
Je confirme, le passage sur Sierra redonne accès à l'API Metal. Heureusement que mon Mac pouvait faire la migration sinon j'aurais vraiment été faché contre Blizzard
Oui si tu passes sous Sierra 10.12.0 tu peux récupérer l'API, au même titre que si tu dispose d'une carte Pascal tu as besoin de la 10.12.4 pour qu'elle soit prise en compte, bien qu'elles ont besoin du Web Drivers contrairement aux précédentes architectures qui sont supportées "nativement".

Web Drivers qui nécessitent la 10.12.4 justement, car c'est uniquement à partir de cette version qu'il y a un support GTX10 / Titan3 (et probablement Titan4 d'ici plusieurs mois).

D'ailleurs ça me fait penser qu'il faut que je vérifie si j'ai bien Metal vu que j'ai deux GTX 1070.
Tiens.. c'est mieux de jouer sous MacOS ou de booter sous Windows?
Je suis sur un iMac 5KRetina et je boot sous Windows pour jouer à WoW.
J'avoue que j'voudrais bien gagner en perf si ya moyen.
Bonjour,

à la dernière maj 7.3.5 , un point d'exclamation est apparut sur la pages des personnages me siganlant qu'a la prochaine extension mon le jeu ne serait plus compatible je suis sur El capitan et Apple me bloque Sierra. Voici ma config
Nom du modèle : iMac
Identifiant du modèle : iMac7,1
Nom du processeur : Intel Core 2 Duo
Vitesse du processeur : 2,8 GHz
Nombre de processeurs : 1
Nombre total de cœurs : 2
Cache de niveau 2 : 4 Mo
Mémoire : 4 Go

Je suis en colère, j'adore mon mac qui est un 27 pouces , j'ai 2000 euros à sortir pour pouvoir jouer à Battle for Azeroth........
22/01/2018 02:18Publié par Absolutiøn
Bonjour,

à la dernière maj 7.3.5 , un point d'exclamation est apparut sur la pages des personnages me siganlant qu'a la prochaine extension mon le jeu ne serait plus compatible je suis sur El capitan et Apple me bloque Sierra. Voici ma config
Nom du modèle : iMac
Identifiant du modèle : iMac7,1
Nom du processeur : Intel Core 2 Duo
Vitesse du processeur : 2,8 GHz
Nombre de processeurs : 1
Nombre total de cœurs : 2
Cache de niveau 2 : 4 Mo
Mémoire : 4 Go

Je suis en colère, j'adore mon mac qui est un 27 pouces , j'ai 2000 euros à sortir pour pouvoir jouer à Battle for Azeroth........

Salut Absolutiøn,
de ce que je sais ( je suis pas un expert je précise)
Les imac 7.1 ne supporte pas le 64b.
de ce fait le jeu ne pourra pas être lancé dessus à la prochaine extension.
C'est lié à une règles imposé par apple comme l'a rappeler zarnalaki dans un autre poste :
Apple a annoncé en juin 2017 lors de la conférence keynote qu'à compter de Janvier 2018, toutes nouvelles applications Mac OS devraient obligatoirement être publiées en 64 bits et qu'à compter du mois de juin 2018, toutes les mises à jour des anciennes applications devraient également l'être.

Cela fait donc 7 mois que l'éditeur de votre système d'exploitation a annoncé ces nouvelles obligations. Il ne nous est pas possible dans ces conditions d'offrir la compatibilité du jeu avec un système quand le développeur de ce système l'abandonne ainsi.
Bonjour à tous,

Pour plus d'informations ces changements, je vous encourage à consulter ce sujet épinglé ou les réponses apportées dans ce fil de discussion.

Je ferme ce ce sujet compte tenu de son ancienneté et pour éviter les doublons. Merci de votre compréhension.

__________________________________________
Zarnalaki, du dimanche au jeudi entre 9h00 et 17h30.
Votre avis nous intéresse !

Rejoignez la discussion

Retour au forum