Can't Use Item Due to Incorrect Level Requirements

Updated: 5 months ago
Article ID: 279095
Relevant Products:

Common Problems

  • Level is too low but I meet the level requirements
  • Cannot learn mount
  • The tooltip requirements are incorrect

We have received multiple reports of this issue and can confirm it is not working as designed. Our developers are working to resolve this as quickly as possible. Currently, we do not have a workaround or resolution.

Be sure to check our Bug Report forums for any new issues. If you discover a new issue, you can report it there or in-game through the bug report feature.